[Update]Cedega, die 1ste

18Apr08

Im Zuge meiner ‚langsamen‘ Migration in Richtung Linux im Privatbereich habe ich erste Schritte getan und mal versucht, eines meiner Spiele – das geliebte/gehasste World of Warcraft – unter Ubuntu Gutsy zum Laufen zu bringen. Da ich gerade etwas zu viel Geld in der Tasche habe und die Screenshots auf der Webseite vielversprechend aussahen habe ich mir ein 3-Monats-Abo von Cedega zugelegt. Ich erwähnte ja schon, dass ich gerne spiele, aber mir das Wine-Gefrickel manchmal auf die Nerven geht.
Nach der Registrierung habe ich mir das Installationspaket heruntergeladen und fix installiert. Die Grundeinstellung werden beim ersten Start durch einen Assistenten durchgeführt, das ganze ist auch für Windows-Anwender recht intuitiv gehalten.
Nachdem dies geschafft war, war ich bereit für den ersten Versuch.
Cedega bietet Vorlagen für Spiele an, also letztlich Konfigurationssets für Grafikeinstellungen, Sound, etc, um die Lauffähigkeit der einzelnen Spiele zu garantieren und zu optimieren. Klingt erstmal ganz gut.
Ich lege die erste Installationscd von WOW ein (Blizzard hatte damals die grandiose Idee, World of Warcraft auf fünf CDs auszuliefern… ohne DVD) und lasse Cedega die CD scannen. Cedega erkennt brav, dass es sich um World of Warcraft handelt; ich wähle aus einem Pulldown-Menü das Konfigurationsset für World of Warcraft und will loslegen. Cedega startet den Installationslauncher, auf dem ich leider nichts anklicken kann. Hm. Kein guter Anfang. Ich bemerke in den Bemerkungen zum Konfigurationsset, dass ohnehin Probleme beim CD-Wechsel zu erwarten sind und empfohlen wird, die Installationsdateien auf einen Ordner auf der lokalen Platte zu kopieren und von dort zu installieren.
Mit der dumpfen Ahnung, dass dies mein erstes Problem auch nicht lösen wird, kopiere ich die fünf CDs in einen Ordner. Etwa eine halbe Stunde später wage ich den nächsten Versuch mit genau demselben Ergebnis. War ja irgendwie klar.
Da ich auch mein Notebook geplättet hatte, hatte ich mir im Vorfeld ein Backup meines WOW-Programmordners auf einer externen Festplatte erstellt (WOW benötigt im Übrigen nicht unbedingt eine Installation, sondern ist durchaus von einem externen Datenträger aus lauffähig und spielbar). Also habe ich geschwind das Backup auf meiner lokalen Platte wiederhergestellt und das Spiel in Cedega eingebunden. Auch hier habe ich ein WOW-Konfigurationsset gewählt – diesmal „World Of Warcraft-Burning Crusade“.
Ich starte das Spiel und der Bildschrim wird schwarz. Lange Zeit geschieht nichts. Dann erscheint der Login-Screen… langsam. Nach einigen Minuten ist er ganz aufgebaut und ein Blick auf die Framerate beweist, was ich vermutet habe: 1 FPS. Ein echter Augenöffner…
Ich verlasse das Spiel, was auch wieder ein wenig Zeit in Anspruch nimmt und verwerfe das ausgewählte Konfigurationsset zu Gunsten des Sets „World of Warcraft“. Auch hier dieselbe rasante Framerate.
Dann nochmal ohne Konfigurationset und mit manuellen Einstellungen, die ich im inoffiziellen Cedega-Wiki gefunden habe. Immerhin erreiche ich eine Framerate von 3-4 FPS. Ich logge mich auch mal ein mit einem meiner niedrigstufigen Charakteren. Das Spiel ist – wie zu erwarten – nicht wirklich spielbar.
Ich verlasse das Spiel und überlege, was man sonst noch machen kann.
Letzte Idee: Ich starte das Spiel in Wine ohne Cedega. Es dauert ein wenig, ich bin im Loginscreen. Ich habe zwar keine Framerate-Anzeige, merke aber, das die Performance erheblich besser ist, vielleicht einen Tick langsamer als unter Windows. Ich logge mich ein und nach ein paar Grafikeinstellung im Spiel kann ich ohne Probleme spielen. Die Darstellung ist gut (einige Details drehe ich normalerweise zu Gunsten der Performanz runter, sehr empfehlenswert in Gebieten mit vielen Spielern), die Framerate wohl recht hoch, keine Lags. Ich musste keine Änderung an der Konfigurationsdatei von WOW vornehmen (wie das in vielen HowTo’s empfohlen wird), das Spiel startet sozusagen „Out-of-the-Box“.
Stellt sich die Frage, wofür ich nochmal Cedega haben wollte? Achja, um mir das Konfigurationsgefrickel zu sparen…

Erstes Testergebnis: Durchgefallen (zumindest bei mir)

Nächster Test: Star Wars Knights of the old Republic II – The Sith Lords, irgendwann die nächsten Tage.

Ich bin gespannt.

Nachtrag vom 28.04.2008:

Ein Test auf meinem Laptop unter Ubuntu 8.04 bringt ein genau umgekehrtes Ergebnis. Hier läuft WOW unter Cedega mit entsprechenden Konfigurationsset tadellos, unter Wine sehr schlecht. Nun bin ich verwirrt. Liegt es möglicherweise an der Wine-Version? Ich bleib dran…
Links zum Thema:
Offizielle Seite „World of Warcraft“
Inoffizielles Cedega-Wiki
WineHQ



3 Responses to “[Update]Cedega, die 1ste”

  1. 1 Gekko

    Da ich kaum bis gar nicht auf dem PC spiele bin ich um dieses Problem bieher herumgekommen – klingt aber recht entmutigend…:/

  2. 2 Maikl

    Entmutigend ist nicht der richtige Ausdruck… es ist ja durchaus möglich unter Linux zu spielen – mit Wine und manchmal sogar nativ.
    Und vielleicht hab ich auch Fehler bei der Einstellung von Cedega gemacht – ist ja nicht auszuschliessen.
    Ich werde auf jeden Fall weiter testen und mal schauen.

  3. 3 bluelaguner

    Kannst du mir vielleicht auch einmal bitte erklären wie ich meine Cedega Software regestriert bekomme?


Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s


%d Bloggern gefällt das: